The website tries to set up a secure connection with the Mollie API. However, the server is unable to set up this connection because of an outdated module.

We recommend you upgrade your OpenSSL module to its latest version. This will not only allow you to connect with Mollie but is generally speaking also important to the overall security of your website.

Unfortunately, we are not in a position to lend any assistance in the updating of the software. If you are unable to update the module yourself, we recommend you contact the hosting provider or server administrator.